关于APX文件导UDK的问题

该主题包含 4 个回复,有 2 个参与人,并且由 陶仁贤 的头像 陶仁贤3 月, 4 周 前 最后一次更新。

正在查看 5 个帖子 - 1 至 5 (共计 5 条)
  • 作者
    帖子
  • #13674
    枫桥镇外的青衫客 的头像
    枫桥镇外的青衫客
    学员
    注册日期: 2015/04/17
    发帖数: 1
    回帖数: 2

    老师您好,我下载了您做的UDK角色自定义全流程的视频,然后我用phys cloth 做布料,导出的APX文件 一导进UDK,UDK就崩溃了,后来我发现只有2012-2月份之前的版本的UDK导才不会崩,可我看您用的是2012-7月份的,您知道是什么原因吗?我场景都做好了换低版本的话会很麻烦···

    #13732
    陶仁贤 的头像
    陶仁贤
    教师
    注册日期: 2014/06/20
    发帖数: 1
    回帖数: 642

    这个问题之前并没有碰到过,短暂研究了一下,预估可能是以下方面的问题
    1. 在maya 或者max 里面做碰撞的时候,你的插件是否是从nvidia官方下载。是否是最新版本
    2. 布料碰撞有些时候对于面比较复杂的布料来说,结算会遇到各种Bug,比如穿透等,尽量保持模型布料的简单。
    3. 你可以把我在教学里面附送的那些布料的内容导入你的UDK试试看,看看会不会出错,绝大部分都是因为模型碰撞太复杂造成的。
    4. 每个版本的UDK都有不同的调整,会出现某个版本可以用,而某个其他版本不能用的说法。
    5. 如果条件可以,试试看转到UE4里面吧,效果提升一大截,而且有源代码,写脚本也不需要这么辛苦了,直接上C++

    #13733
    枫桥镇外的青衫客 的头像
    枫桥镇外的青衫客
    学员
    注册日期: 2015/04/17
    发帖数: 1
    回帖数: 2

    老师您好,我那些插件都是在官网下的,我试过了好几个版本都不行,MAX也试了2011和2012两个版本,测试的时候用的都是最简单的碰撞,比如一个平面和一个球体之类的,还有网上下的教学文件的MAX文件生成出来也是一导就崩,最主要的是我把这些文件传给我的好几个同学,他们也都是一样,所以我还以为这会是个普遍现象,难道只有我们是这样吗?
    我找了一下,您的教学文件里好像忘了放布料的文件了,我最近在赶毕设,所以换UE4的话可以会来不及了··
    真是头大啊 :-? :-?

    #13734
    枫桥镇外的青衫客 的头像
    枫桥镇外的青衫客
    学员
    注册日期: 2015/04/17
    发帖数: 1
    回帖数: 2

    对了老师,我还漏了一个地方,就是我用UDK2012-1之前的版本,导是能导APEX了,但导进去之后把节点连上根本没反应

    #43353
    陶仁贤 的头像
    陶仁贤
    教师
    注册日期: 2014/06/20
    发帖数: 1
    回帖数: 642

    抱歉,好久没有接触UDK了,可以的话,请升级到 UE4吧,在开发效率和难度以及最终出来的画面来看,UE4比 UDK 好太多了。

正在查看 5 个帖子 - 1 至 5 (共计 5 条)

抱歉,回复评论必需登录。